Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#126 closed defect - etc (fixed)

H atom continuum pumping does not reproduce

Reported by: Gary J. Ferland Owned by: nobody
Priority: major Milestone: c13 release
Component: ionization convergence Version: trunk
Keywords: Cc:

Description (last modified by Gary J. Ferland)

in the valentina models she tried these two commands:

pumpoff.in
atom h-like lyman pumping off
hydro.lgLymanPumping
pumpscale.in
atom h-like lyman pumping scale 0
hydro.xLymanPumpingScaleFactor

these should have the same effect but don't - she asked about this on the yahoo site. The two sims are attached.

the active command is given above and the variable it sets is below the command. They do not use the same variable, a design flaw.

why don't they produce identical effects? I have gone over where they are used and found one bug - the upper level is 1 for hydro.lgLymanPumping but is 2 for hydro.xLymanPumpingScaleFactor

I propose changing the 2 to 1 in iso_solve.cpp:66 and 384

even with this change the output of the two sims is not the same. there must be other problems.

this change causes a few blr fail to fail monitors on my mac. H I Pa in one. I have not made the change in the repo since there is clearly more going on than I understand right now.

Attachments (2)

pumpoff.in (38.2 KB) - added by Gary J. Ferland 8 years ago.
pumpscale.in (38.2 KB) - added by Gary J. Ferland 8 years ago.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by Gary J. Ferland

Attachment: pumpoff.in added

Changed 8 years ago by Gary J. Ferland

Attachment: pumpscale.in added

comment:1 Changed 8 years ago by Gary J. Ferland

Description: modified (diff)

comment:2 Changed 8 years ago by Gary J. Ferland

Description: modified (diff)

comment:3 Changed 8 years ago by Gary J. Ferland

Description: modified (diff)

comment:4 Changed 8 years ago by Gary J. Ferland

Ryan sent this email

The "scale" option only applies in the scope of iso_solve. The "off" option kills it dead, as they say. So the latter affects line populations and RT, while the former only affects populations.

The proposed upper level loop index change should have negligible effect. It would only scale two-photon pumping and, again, only in the population solver.

The pump scaling is a fairly ugly hack. Scaling the continuum itself would be much cleaner, I think.

comment:5 Changed 5 years ago by Ryan Porter

Resolution: fixed
Status: newclosed

Works fine now, although the problem as posed in this ticket is no longer valid. The zero in second model is now interpreted as a log, so you get unity and nothing changes. I just tried -30 and got identical .out .dr and .ovr files. Closing ticket.

comment:6 Changed 5 years ago by Ryan Porter

Milestone: C10 releasec13 release

Milestone C10 release deleted

Note: See TracTickets for help on using tickets.