Opened 7 years ago

Closed 7 years ago

#165 closed defect - failed assert (fixed)

assert thrown iso_level.cpp:472

Reported by: Gary J. Ferland Owned by: nobody
Priority: major Milestone: C13 branch
Component: ionization convergence Version: trunk
Keywords: Cc:

Description

the attached aborts quickly. This was sent in my Orly Gnat who was trying to compute the cooling due to individual stages of ionization - she did several tricks to get unit copper abundance.

the root cause may be something related to underflow due to the extreme densities encountered? But, if this is bound to happen, the ion stage trimming logic should have caught it before sending to the iso solver??

Attachments (1)

noch.in (1.2 KB) - added by Gary J. Ferland 7 years ago.
input script for assert

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Gary J. Ferland

Attachment: noch.in added

input script for assert

comment:1 Changed 7 years ago by Ryan Porter

Resolution: fixed
Status: newclosed

Fixed in r4125. Also caused major changes in a number of other fixed ionization models. Setting ground density to stage density was the problem there.

Note: See TracTickets for help on using tickets.