Opened 7 years ago

Closed 5 years ago

#174 closed defect - convergence (duplicate)

non-convergence with full chianti enabled

Reported by: Gary J. Ferland Owned by:
Priority: major Milestone: C13 branch
Component: atomic/molecular data base Version: trunk
Keywords: Cc:

Description (last modified by Gary J. Ferland)

testing with all of chianti turned on reveals only one abort, the sim blr_n09_p22_Z20. the symptoms are mysterious

getting to zone 16, where the first convergence failure is announced, takes several hours. the code is clearly thrashing.

typical ionization at this point is roughly Fe 21 +/-2

there is a thermal front in this model, so I checked whether too large a dr near that front could be a cause. The save dr output was not produced. there were only the first dr choices - the zone dr was never reported. so, "save dr" does not work in this test.

the convergence failure is not due to a thermal front - constant temperature also fails

Change History (6)

comment:1 Changed 7 years ago by Gary J. Ferland

Description: modified (diff)

comment:2 Changed 7 years ago by Gary J. Ferland

Description: modified (diff)

comment:3 Changed 7 years ago by Gary J. Ferland

the save convergence file shows that the code is struggling to converge the heating and cooling starting early in the calculation. by zone 10 it is having problems. debugging will be faster if earlier zones are examined.

comment:4 Changed 7 years ago by matt

The sim now completes without a convergence failure when constant temperature is set.

comment:5 Changed 7 years ago by matt

The sim also completes without a convergence failure if "no line ots" is added to the input file.

comment:6 Changed 5 years ago by Ryan Porter

Resolution: duplicate
Status: newclosed

Closing as duplicate of #189.

Note: See TracTickets for help on using tickets.