Opened 7 years ago

Closed 7 years ago

#178 closed defect - convergence (fixed)

atom leveln called with too-low temperature for highest level, does nothing

Reported by: Gary J. Ferland Owned by: nobody
Priority: critical Milestone: C13 branch
Component: thermal convergence Version: trunk
Keywords: Cc:

Description

changes in r4204 announced when atom not solved by atom_leveln at atom_leveln.cpp:289. this produced vast amounts of output, which is now silenced by a debug enum posted in r4207.

this trip is caused by the highest level having no entry rates from ground. the routine exits without solving the atom. The total cooling is then zero.

This is a bug since there may still be significant cooling from low levels. The routine should decrease the number of levels until a highest level with a positive excitation rate is reached. This bug could affect the cooling, by either underestimating it, or causing noise as the highest level excitation rate was either positive or zero.

Change History (1)

comment:1 Changed 7 years ago by Gary J. Ferland

Resolution: fixed
Status: newclosed

fixed in r4214

Note: See TracTickets for help on using tickets.