Opened 7 years ago

Closed 7 years ago

#183 closed defect - FPE (fixed)

memory violation with database lines, trunk & c10 branch

Reported by: Gary J. Ferland Owned by: nobody
Priority: critical Milestone: C13 branch
Component: etc Version: trunk
Keywords: Cc:

Description

attached segfaults at pressure_total.cpp:904, where database line label is copies to chLineRadPres ipLinePradMax is 6744

gcc 4.2.1 on 64 bit mac

Attachments (1)

p1.in (366 bytes) - added by Gary J. Ferland 7 years ago.
Wang Ye script - segfault is on c10 and trunk, ss option on hextra is irrelvant

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Gary J. Ferland

Attachment: p1.in added

Wang Ye script - segfault is on c10 and trunk, ss option on hextra is irrelvant

comment:1 Changed 7 years ago by Gary J. Ferland

the species label is H2O and is properly null terminated.

comment:2 Changed 7 years ago by rjrw

It looks like the problem is at pressure_total.cpp:635, where ipLinePradMax is set to a value i which isn't defined in the loop (i.e. isn't the index of the transition).

The other cases in this routine are done by iterating over lines in the lists, not over upper and lower states.

comment:3 Changed 7 years ago by Ryan Porter

Resolution: fixed
Status: newclosed

Fixed in r4278.

Note: See TracTickets for help on using tickets.