Opened 6 years ago

Closed 3 years ago

#224 closed defect - convergence (fixed)

the problem preventing convergence for some BLR (&other) sims

Reported by: Gary J. Ferland Owned by: nobody
Priority: major Milestone: C17_branch
Component: radiative transfer Version: trunk
Keywords: Cc:

Description

We have long had a problem with some lines in BLR sims hopping around, from rev to rev, or the same rev with different compilers. This quantifies some of the things that are happening.

A separate branch, , and ran blr_rnfb, one of the more problematic sims. Here is the original email of 2012 Jan 3

here are ten iterations of the blr_rnfb sim - the number is the optical depth reported by the
print line optical depth
command.  (I replaced "iterate convergence" with "iterate 10" to do this)

O I 1304:
O  1 1304A 2.62e+06
O  1 1304A 2.67e+06
O  1 1304A 2.65e+06
O  1 1304A 2.66e+06
O  1 1304A 2.65e+06
O  1 1304A 2.65e+06
O  1 1304A 2.65e+06
O  1 1304A 2.65e+06
O  1 1304A 2.65e+06
O  1 1304A 2.65e+06

so 1304 was pretty well converged by the third iteration.

8446 has major issues:
O I 8446
O  1 8446A 1.09e+02
O  1 8446A 2.04e+02
O  1 1039A 3.84e+05
O  1 8446A 1.96e+02
O  1 8446A 1.89e+02
O  1 8446A 1.54e+02
O  1 8446A 1.54e+02
O  1 8446A 1.83e+02
O  1 8446A 2.37e+02
O  1 8446A 1.82e+02

it was making progress toward a lower optical depth, approaching 153 as Peter said in an earlier email, until the 9th iteration when it jumped very high. This is not a monotonic progression. It is hard to understand because the 1304 optical depth was constant so the population of the lower level of 8446 should have been fairly constant. is it possible to tell what happened to the update at the 9th iteration?

Attachments (2)

LineOpticalDepths.pdf (20.4 KB) - added by Gary J. Ferland 6 years ago.
line optical depths, old and new, for 10 iterations
level6.pdf (9.8 KB) - added by Gary J. Ferland 6 years ago.
population of level 6, (4 was similar, and 5 was stable)

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by Gary J. Ferland

Attachment: LineOpticalDepths.pdf added

line optical depths, old and new, for 10 iterations

comment:1 Changed 6 years ago by Gary J. Ferland

Robin's note about how line optical depths could be updated:

FWIW, seems like what the solver may need to do in this case is

i) forget trying to maintain a bracket -- dependency on unknown unknowns means old values may be irrelevant

ii) only use the last two iterations in deriving the next sample point -- ditto

iii) limit the stepsize to a maximal value, which should be the more restrictive of

a) some factor (2x?) the distance between the previous two iterations

-- replaces bracketing constraint

b) some factor (somewhere between 10-50%, perhaps reducing with

iteration?) of the absolute value of the previous iteration -- should prevent nonlinear couplings causing oscillations

Making (iii) a limit rather than a damper means that you should get fast convergence once you're close to a solution.

Changed 6 years ago by Gary J. Ferland

Attachment: level6.pdf added

population of level 6, (4 was similar, and 5 was stable)

comment:2 Changed 6 years ago by Gary J. Ferland

Peter looked at the level populations, created the attached level6.pdf, and noted the following:

I finally got around to plotting the data. Attached are 3 plots showing the populations of levels 4, 5, and 6 in the last 4 iterations. Two things are remarkable. First, in all 4 iterations the level pops are pretty much identical up to a depth of ~7e10 cm, then they jump apart in a single zone. Taken at face value, I would think that this cannot be caused by the total opacity jumping around. I would expect a more gradual effect towards the outer edge in that case (also I would expect at least the 8446 line to be still optically thick at that depth, but I haven't checked that in detail). The second remarkable thing is that levels 2, 3, 4, and 6 show similar behavior with jumps at ~7e10 cm, but for levels 1 and 5 this effect is absent. For level 1 this can be understood, but not for level 5. This should be an important clue to the origin of this effect. If Ly beta pumping was the only process populating level 6, then I would expect population changes to trickle down to level 5 as well...

The zoning looks pretty coarse around 7e10 cm. Maybe that is (in part) to blame??

comment:3 Changed 6 years ago by Gary J. Ferland

this is on cloudy dev thread with title BLR convergence problems for the past year or so

comment:4 Changed 3 years ago by Gary J. Ferland

Milestone: C15_branch

comment:5 Changed 3 years ago by Gary J. Ferland

Resolution: fixed
Status: newclosed

changed to fixed since this is not a valid description of where we are in mid 2014. Replaced with ticket #289

Note: See TracTickets for help on using tickets.