Opened 10 years ago

Closed 5 years ago

Last modified 5 years ago

#65 closed defect - convergence (wontfix)

chemistry solution is greatly disturbed for no apparent reason

Reported by: Gary J. Ferland Owned by: nobody
Priority: critical Milestone: c13 release
Component: chemical network Version:
Keywords: chemistry solver bonkers Cc:

Description

the attached bug.in falls over. with trace convergence print turned on we see that the solver has happily found that a solution is somewhere around 9200K. the chemistry falls apart when the solver changes modes.

bug.out shows what happened. Through line 130 of the output things are on track. The print at line 132 occurs at line 570 of conv_init_solution.cpp.

the trouble starts during the call to ConvPresTempEdenIoniz? at line 616 to conv_init_solution.cpp. This happens at a temperature of 9216K at printed at line 135 of the output - the previous temperature at line 130 was identical to all printed figures so T may not have changed at all. A series of chemistry failures occur which are fatal.

something really kicked the chemistry network at this point even though the external conditions appears to have not changed.

is it possible to see what rates going into the chemistry changed by large amounts? this does not appear to be something subtle - the solver totally jumps the rail.

this does not occur if the large H2 is turned off - could there be comething from the H2 chemistry done by the large H2 model that has not been evaluated but suddenly is?

Attachments (1)

ChemistryBonkers.tgz (28.8 KB) - added by Gary J. Ferland 10 years ago.
bug.in is input, .out is output, two other files are needed in same dir

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Gary J. Ferland

Attachment: ChemistryBonkers.tgz added

bug.in is input, .out is output, two other files are needed in same dir

comment:1 Changed 8 years ago by (none)

Milestone: C09

Milestone C09 deleted

comment:2 Changed 7 years ago by rjrw

Can no longer be reproduced because the input transmitted continuum is out-of-date.

comment:3 Changed 7 years ago by rjrw

Milestone: newmole onto trunk

comment:4 Changed 5 years ago by rjrw

Milestone: newmole onto trunkC10 branch

comment:5 Changed 5 years ago by Ryan Porter

Resolution: wontfix
Status: newclosed

Can't reproduce. Has almost certainly been fixed with introduction of newmole anyway.

comment:6 Changed 5 years ago by Ryan Porter

Milestone: C10 branchc13 release

Milestone C10 branch deleted

Note: See TracTickets for help on using tickets.